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MasterTemplate for ArchiCAD 20 (AMT20) has been prepared with the following 
key principles: 

1. Incorporate all of the new ArchiCAD 20 features. 
2. Continue forward all of the time-saving features and file structure from 

previous versions of MasterTemplate. 
3. Upgrade the project workflow with useful new ideas and content, and 

rework and adjust the template to improve performance. 
4. Provide maximum compatibility with standard Graphisoft templates, 

libraries and other resources. 

Upgrading projects and customized templates made in earlier versions of 
MasterTemplate to ArchiCAD 20 may be done simply (without upgrading 
attributes such as Surfaces and Building Materials) or in a more elaborate 
process (to gain full compatibility with all the new technology improvements 
provided by Graphisoft). 

NOTE: If you’re just starting to use MasterTemplate, you don’t need 
to follow the steps included in this document.  

Instead, follow the directions given in the member area in the Quick 
Tutorials videos and the MasterTemplate Training videos to get started. 
You’ll create a copy of the “stock” template files so that you can customize 
them for your firm, and add your company information to the title blocks in 
the layout masters.  

At that point, you can start a real project and get going, and customize the 
template more later if you need to. 

If you have been using MasterTemplate and are upgrading to ArchiCAD 20, then 
this document will introduce you to the new or changed features, and give you 
guidance for how to migrate your project files and your customized template. 
 



OVERVIEW OF MASTERTEMPLATE NEW FEATURES FOR ARCHICAD 20 

In ArchiCAD 20, Graphisoft focused much of the improvements on refreshing and 
streamlining the interface.  

All the icons have been updated in the Toolbox, toolbars, palettes and dialog 
boxes. They also revised the user interface to make it easier to navigate around 
the project using the Quick Options Bar and the expanded options in the Tab 
Bar. 

In some versions of ArchiCAD, menus have been rearranged into a more logical 
or simpler manner (e.g. in the US version the Element Attributes submenu has 
been moved up to sit directly under the main Options menu). Toolbars have been 
reworked so that more frequently used commands are easily at hand. 

These improvements do not affect template files, although they take a bit of 
getting used to. Ultimately, of course, they’re notable in terms of boosting 
productivity by making daily tasks faster and easier to accomplish. 

There are two MAJOR changes in ArchiCAD 20 that created opportunities for 
improvements in MasterTemplate, enhancing the project workflow: 

• Graphical Favorites – the dramatically revamped and expanded system 
for creating and managing favorites, the settings for frequently used 
elements 
 

• Properties – the new data fields associated with Virtual Building 
elements, which can be used for annotations as well as reported in 
schedules and exported to BIMx and IFC 



GRAPHICAL FAVORITES 

ArchiCAD 20’s new Graphical Favorites are a huge improvement, providing quick 
access and much easier management of frequently used settings.  

MasterTemplate pioneered a graphical approach to Favorites in 2007 with the 
Interactive Legends of Visual Favorites. In AMT20, all of the individual elements 
arrayed in the Legends “kit of parts” have now been set up in the Graphical 
Favorites for even easier usage. 

While the new AC20 Graphical Favorites are fantastic, they do not completely 
replace or supersede the Legends.  

The Legends provide a method for visually scanning and reviewing large sets of 
elements and comparing them to each other. Picking the desired element from 
the array of components can be easier in some cases than the new Graphical 
Favorites palette system, since one can look at them more closely, and 
annotations, notes and visual cues can be seen in context.  

In addition, the Legends contain a number of QuickRooms: configurations of 
multiple elements as prototype arrangements for residential kitchens, baths and 
other rooms as well as commercial offices, lobby and restrooms etc. 

One can quickly copy a QuickRoom and paste into your project, then rework as 
needed to suit your design. This approach can speed up creating conceptual 
layouts and in some cases be retained and developed for inclusion in the actual 
project. It is extensible and customizable, since you can save your own 
QuickRooms in the Office Favorites Legend file. 

The QuickRoom concept is not adaptable to the AC20 Graphic Favorites palette, 
and thus is uniquely positioned in the project file structure using the Legends 
system.  

Thus the Interactive Legends “live on”, providing a uniquely visual approach to 
room configurations as well as study and selection of components for placement 
into your active project. 



PROPERTIES, LABELS AND INTERACTIVE SCHEDULES 

ArchiCAD 20 introduces a new Properties system for creating data fields 
associated with elements in the project for a variety of purposes. 

These Properties can be displayed as annotations using associative Labels, 
extending the Label options that were introduced in ArchiCAD 19.  

In AMT20, the Interactive Legends have been annotated using associative labels 
to show names of library parts, composites or surfaces as well as dimensional 
information.  

BACKGROUND NOTE: 

In AMT19, a new set of Interactive Schedules were introduced for Keynote 
and Specification Reports. These were based on data set up as custom 
IFC fields, which for the first time allowed Virtual Building elements of 
multiple types to share common information in schedules. 

The approach had its drawbacks in terms of speed (refreshing the 
schedules could take a long time in larger projects) and access. IFC fields 
were not instantly available for data input, requiring diving deeply into 
dialog boxes or special schedules to add or edit the information. 

In ArchiCAD 20, the new Properties system is elegantly integrated into the Info 
Box, standard element Settings dialogs, as well as the Interactive Schedule 
scheme setup interface. In addition, properties can be made applicable only to 
relevant elements (e.g. Fire Resistance is normally only shown for structural 
elements, not objects; Glazing is only displayed as a Property for doors, windows 
and curtain walls, etc.).  

Option sets allow dropdown menus of choices, speeding up and systematizing 
data input. Schedules can be exported into spreadsheets, filled out by staff or 
consultants, then re-imported into the project, extending the BIM workflow 
beyond ArchiCAD’s native environment. 

All of the Keynote and Specifications schedules introduced into AMT19 have 
been reworked to use the new Properties system, making the entire process 
much easier to implement. 

The new Properties as well as Interactive Schedules introduced in AMT20 can be 
easily imported into a customized template or project that is being migrated into 
ArchiCAD 20. 



DEVELOPMENT NOTES: CREATING MASTERTEMPLATE FOR AC 20 

MasterTemplate 20 required just a modest amount of work to provide basic 
compatibility with ArchiCAD 20.  

AMT19 was imported into ArchiCAD 20 and the library was migrated. Most 
Legend components were automatically migrated to use the new library, however 
some were left by ArchiCAD to reference the older library. In each case, manual 
inspection allowed me to pick a suitable match for the element in the new library, 
so AMT20 now uses only the standard ArchiCAD 20 Library, in conjunction with 
the embedded AMT Library folder. 

Since the new Properties system obviates the need for the custom IFC fields 
used in AMT19, these AMT data fields were removed from the IFC Scheme 
introduced in AMT19.  

All references to these IFC fields were deleted from the Legend elements as well 
as the initial example building used to provide context for the Specification 
Schedules.  

A new set of Properties for AMT20 were introduced to replace the IFC fields, 
organized under the AMT folder (inside the Properties system).  

They include: 

• DIVISION - the CSI Division (U.S.) or main grouping for the general 
Specifications Schedule  

• CATEGORY - CSI Subdivision or general Trade reference for individual 
schedules  

• DRAWING NOTE - for use in the associative Label on appropriate 
drawings  

• GENERAL DESCRIPTION - primary description or note  
• WORKMANSHIP NOTES - secondary description for more extensive 

notes  
• COST - cost per element  
• WEB LINK - reference information (linking to a web page or PDF, or a 

“permanent” link for the project set up using Dropbox) 

Some elements in the example building have these Properties set up so that it is 
easy to see how they are used and referenced in the Specifications reports in the 
Interactive Schedules. 



QUICK MIGRATION OF CUSTOMIZED TEMPLATES AND ACTIVE 
PROJECTS FOR ARCHICAD 20 

Here is a step-by-step process to migrate your customized template or project 
which will integrate most of the new features of AMT20: 

1. Save a backup copy of your template or project before proceeding; if 
anything goes wrong, you’ll have this to refer to or to work with. 
 

2. Start up ArchiCAD 20, open up your template or project. Allow ArchiCAD 
to migrate your Libraries. 
 

3. Ignore the messages about certain files being unavailable for update; 
these are natural since ArchiCAD 20 will only update hotlinks 
automatically for AC20 files. You’ll clean these up later. 
 

4. After the file is fully open, make a quick review to see that everything looks 
OK. Make note of anything that appears to be missing or changed; correct 
it now if you wish. (Most likely things will appear the same.) 
 

5. Import the AMT20 Properties.  
 
NOTE: It’s important to do this first, BEFORE the other steps, since this 
sets up the new data fields in your file. 

a. Open up the Options menu > Property Manager command 
b. Click the Import button near the bottom 
c. Browse and select the AMT20-USA-Properties.xml or AMT20-INT-

Properties.xml file from the MasterTemplate Supplemental Files 
folder 

d. Click OK and all of these Properties will now be in your file 
 

6. Replace the Interactive Legends with the AMT20 versions: 
a. Open up the File menu > External Content > Hotlink Manager 
b. Select the Interactive Legend file, then use the Relink from File 

option to browse for and select the new version from the 
MasterTemplate Linked Files folder. 

c. Repeat for the Office Favorites and Project Favorites files. NOTE: If 
you actually have created your own Office Favorites or Project 
Favorites files, you may migrate them to ArchiCAD 20, save the 
new versions, then relink to your customized files. 

d. Use the Update button to complete the process of replacing the 
Legends with the AMT20 versions. 
 



7. Add or replace the Interactive Schedules with AMT20 versions 
a. If you are migrating from AMT19, you’ll want to delete the old 

versions of the IFC-based schedules. 
i. Open up any interactive schedule, then click on the Scheme 

Settings button in the upper right 
ii. Select and delete AREA-01, 02 and 03 schedules (Gross 

Areas, Glazing and Shadow Calcs) 
iii. Select and delete all Specification Schedules (their IDs start 

with “SP-“) 
iv. You can shift-click and/or CTRL or Command-click to select 

multiple schedules, then use the Delete button and confirm. 
b. Use the Import button at the bottom of the Scheme Settings dialog 

and browse for then select all of the schedules in MasterTemplate 
Supplemental Files > IMPORT FILES (for AMT Upgrades) > 
AMT20-USA-Schedules [AMT20-INT-Schedules] folder. (You can 
select multiple ones, or all of them by clicking on the first one in the 
list then shift-clicking the final one.) 

c. These new schedules will be available for use immediately. 
 

8. Import the Graphical Favorites 
a. Open up the Favorites palette using either the Window menu > 

Palettes > Favorites command or the shortcut button in the Toolbar 
b. Optional: organize your current favorites into one or more folders to 

avoid having them get mixed up with the ones you’re about to 
import. For guidance, see the ArchiCAD 20 reference manual from 
the Help menu, or watch one of the videos that Graphisoft provides. 

c. Press down on the gear icon in the upper right, and select the 
Import/Export option. Select Import > File (ARCHICAD Project or 
PRF) and click the Import… button. 

d. Browse for and select the AMT20-USA-Favorites.prf or AMT20-
INT-Favorites.prf file from the MasterTemplate Supplemental Files 
folder. 

e. You’ll have a choice of importing all of them or some of them. If any 
Favorites have the same name as ones that already exist in your 
file, they will initially say “Overwrite” but you may choose to bring 
them in as additional items by selecting “Append”. Note that you 
may sort by any column, including the Import Option; this will allow 
you to see and select these in a group using shift-click, and 
possibly uncheck (to not import them) or change the Import Option. 

f. Make sure the Import Folder checkbox is checked; this will retain 
the folder organization for these favorites. 

g. When you’re ready, click Import, and the new Favorites will be 
instantly brought in, available for use. 

h. If you want to start fresh, use the downward arrow next to the 
Import button and choose Delete All before Import. 



i. OPTIONAL: Review these Favorites and reorganize now or later to 
suit your preferences and needs. 
 

9. OPTIONAL: Replace the sample building, and remove the AMT custom 
fields from the IFC Scheme. 

a. If you like having the sample building to study, you may replace the 
old one with the latest version. Switch the Layer Combination to * 
SHOW & UNLOCK ALL LAYERS, then navigate to the sample 
building. With groups active, select an element in the sample 
building or a yellow information label. All elements of the building 
and information labels will be selected, and you can delete them. 

b. Open up a fresh copy of AMT20, and select the sample building in 
the same way and copy it. Return to your new template file and 
paste it in. 

c. The AMT IFC fields introduced in AMT19 may be left in the project 
file structure without any issue. However, if you want to clean this 
up to remove these obsolete data fields, you can use the File menu 
> Interoperability > IFC > IFC Scheme Setup… command. (NOTE: 
You neeed to be in the floor plan to access this command.) Select 
IfcElement or IfcBuildingElement and you’ll see the AMT data 
fields. Click the red X to delete them, then click OK to confirm. 
 

10. OPTIONAL: Update your attributes to use the latest versions from 
Graphisoft.  

a. It is possible that some of the attributes (building materials, 
surfaces, etc.) have been updated and improved; I haven’t seen 
any evidence of this, however it is a possibility.  

b. Fortunately, one can very quickly bring in the latest versions from 
the Graphisoft standard ArchiCAD 20 Template file using Attribute 
Manager. 

c. Open up Options menu > Attribute Manager. In the US version of 
ArchiCAD, it’s now in the main Options menu; in the INT version it’s 
still buried in the Element Attributes submenu. 

d. On the right hand side, click the Open button and browse for and 
select the ArchiCAD 20 Template file (found in the ArchiCAD 20 
folder, inside Defaults > ArchiCAD). 

e. Click the tab for Building Materials, then select all of the items on 
the right side (the default ArchiCAD 20 template). Make sure the 
Include Cut Fills and Surfaces checkboxes are checked. Use the 
<< By Name button to overwrite the corresponding Building 
Materials with the same name. 

f. Repeat for the Surfaces, Complex Profiles, Composites and Fills. 
g. All of the revised Attributes should be ready for use. This should not 

affect any AMT-specific attributes. If you have created your own 
composites or complex profiles that reference default building 
materials or surfaces, they will now use the revised versions. 



h. If you have any doubt about proceeding with this step, you can wait 
and do it later, or perform the operations on a test file and examine 
it carefully for any changes. 

That’s it!  

Your migrated template is now available for use, with updated Legends, 
Properties, Schedules and Favorites. 

Additional notes will be provide later in August to explain the new features in 
depth. The MasterTemplate Manual will be rewritten in September to provide a 
comprehensive, current guide to implementing and customizing the template for 
your office. 
 
Please send any questions, comments or feedback to support@bobrow.com. 
 
Eric Bobrow 
August 20, 2016	  


