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The Cadimage Legends add-on for the ArchiCAD MasterTemplate provides quick access to a kit 
of parts for many of the Cadimage Tools products. It is designed to be easily added to your 
customized office MasterTemplate as two separate Hotlinked Modules, one for 3D components 
and one for Rapid Detailer 2D elements. 

Cadimage Legends is supplied as a PLN file with three stories. The lowest floor contains the
legend groupings for Window Builder and Door Builder, Cabinet Builder, Design Suite, 
Landscaping Tools, Landscaping Extras, and Accessory Tools. There is also a blank legend 
frame set up for you to add your own favorite elements.

The story above that in the PLN file is used as a spacer, since some of the roof accessories show 
one story up. 

The top story is used for the Rapid Detailer Legend, which is at a larger scale:



In addition to the Legends themselves, there are Default presets for Door and Window Builder to 
speed up changing from one shape to another, and an optional Work Environment scheme and 
overall profile.
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DOWNLOAD INSTRUCTIONS
The Cadimage Legends are supplied as a download from the ArchiCAD MasterTemplate website 
(http://www.archicadtemplate.com). Click the DOWNLOAD link in the navigation bar, and Login 
with the email address and password registered during your purchase.

On the Download page, there are links for each of your licensed MasterTemplate products.
Download the Cadimage Legends zip file and extract the contents. You’ll see there are three 
items:

1. AMT CADIMAGE LEGENDS USA/INT 13.pln
2. A folder called “AMT CADIMAGE Work Environment”
3. A folder called “Put contents into - ArchiCAD 13 - Cadimage Tools Extras - Defaults”

Move the Cadimage Legends PLN file and the Work Environment folder into your main 
MasterTemplate folder, alongside the MasterTemplate.TPL file. You may use ArchiCAD’s Options 
menu > Work Environment to Import the AMT CADIMAGE Work Environment if you wish. For 
more information on installing an AMT Work Environment, see the section near the end.

Open up the folder called “Put contents into - ArchiCAD 13 - Cadimage Tools Extras - Defaults” 
and select the AMT folder from inside it, and drag or copy/paste it into your ArchiCAD 13 / 
Cadimage Tools Extras / Defaults folder. This is the recommended location, however, it actually 
can go anywhere you wish. You’ll access it “on the fly” by browsing for a shape preset file within 
this folder while in the Door Builder or Window Builder settings dialog box.

If you are just getting started with AMT and purchased the Cadimage Legends along with a new 
license of AMT, please be sure to download the combined AMT with Cadimage TPL file (available 
from the download page). This simplifies initial setup, since the Cadimage Legends are already 
integrated into this copy of MasterTemplate. You still need to download the main Cadimage 
Legends zip file (as above), but will not have to Hotlink it into the template or create Views, since 
that has already been done. You’ll follow the instructions for initial setup of the Cadimage 
Legends PLN file (below) but then be able to jump straight to the section on the USE OF THE 
CADIMAGE LEGENDS.



INITIAL SETUP AND CLEANUP 
Start ArchiCAD 13, and Open the Cadimage Legends PLN file. If necessary, help Library 
Manager find the MasterTemplate Library, as well as your Cadimage Libraries if they are not 
located within the standard ArchiCAD 13 Library folder.

If you haven’t purchased all of the Cadimage Tools, you will have some missing library parts. You 
will need to clean this up (for detailed steps, see the next two paragraphs) by deleting from the 
Cadimage Legend PLN file the Legend groups or elements that are unavailable - these will be 
shown with “dots” on the floor plan.

In the View Map double-click the CADIMAGE TOOLS LEGENDS | ALL view. You’ll see all the 3D 
components in the Legends, arranged in groups. Delete any elements that you do not own that 
are shown as “missing dots”. (If you later buy additional Cadimage Tools, you can copy these
back again from the original Cadimage Legends PLN included in your downloaded zip archive 
file.) After deleting the missing objects for any Tool that you do not own (for example, Cabinet 
Builder), you can leave the Legend group frame if you wish, or delete it.

In the View Map, double-click the RAPID DETAILER | ALL view. If you do not own Rapid Detailer, 
you’ll see lots of dots indicating missing library parts. In that case, select everything in this view 
and delete it. 

Return to the CADIMAGE TOOLS LEGENDS | ALL view, then Save the PLN file. You may close 
this file when you follow the next steps (below), since your Cadimage Legends PLN file is fully 
ready for hotlinking into MasterTemplate.

• FOR NEW AMT USERS ONLY: MASTERTEMPLATE + CADIMAGE TPL

If you haven’t customized MasterTemplate yet, you can work with a version of MasterTemplate 
that has the Cadimage Legends already integrated (MasterTemplate 13 USA/INT TEMPLATE 
with CADIMAGE.tpl). Download that file from our website.

During the standard installation of MasterTemplate, all Hotlinks need to be checked, relinked and 
updated. Follow the directions in the QuickStart Guide for opening Hotlink Manager. 

In addition to the standard Hotlinks (AMT Legends, AMT Office Favorites and AMT Project 
Favorites) you’ll see two references to AMT CADIMAGE Legends in the upper section of the 
Hotlink Manager. While you’re updating all the standard Hotlinks (using the Relink…from File 
popup), you’ll need to do this for the Cadimage Legends as well. Note there is only one reference 
in the Hotlink Sources panel, since both Cadimage Legends come from the same PLN file.

Once you have updated the Hotlinks, you can skip all the rest of the installation and configuration 
steps in this guide, since everything has already been set up in the integrated MasterTemplate 
file you downloaded. Of course, we suggest you follow the rest of the QuickStart Guide and 
consult the main MasterTemplate Manual for general guidance. When you are ready, skip to the 
section in this document for USE OF THE CADIMAGE LEGENDS.

• HOTLINKING THE CADIMAGE LEGENDS INTO MASTERTEMPLATE

If you are an existing user of MasterTemplate, you’ll need to open up your customized office 
template and modify it to integrate the Cadimage Legends. It is a good idea to backup your 
current office template file before you make any significant modification. We recommend 
duplicating the TPL file (you may simply Copy, then Paste) and changing the name of the 
duplicate (to indicate the date or add “before Cadimage” to the name) rather than the name of the 
active TPL file. This allows all bookmarks or references to the TPL in popups to remain intact.

Inside ArchiCAD, select File menu > Open > Open…, and choose from the “Files of type:” popup 
“ArchiCAD Project Template (*.tpl)”. Browse and select your custom MasterTemplate TPL file,
and click Open. 



You’ll need to go to the right location in the TPL file to place the Hotlink for the Cadimage 
Legends. In the View Map, expand the INTERACTIVE LEGENDS (FAVORITES) > LEGENDS | 
PLAN folder, and double-click LEGEND 3D | ALL. 

NOTE: It is important you use this View from the LEGENDS | PLAN folder, which takes 
you to a part of the floor plan, rather than the similar view in the LEGENDS | 
WORKSHEET folder (since that brings up a Worksheet with the Plan view shown as a 
Virtual Trace reference).

Open the File menu > External Content > Place Hotlinked Module… Check and make sure the
Master Layer is set to A | * MASTER - MODULE | LEGEND.*MOD, then click the button to 
Choose Hotlink…

In the Choose Hotlink dialog box, choose New Hotlink… > from File:

then browse and select the Cadimage Legends PLN file. 

TIP: In the New Hotlink dialog, you may need to switch the “Files of type:” popup to 
“ArchiCAD Solo Project (*.pln)” if it isn’t set to that already:

In the Choose Story dialog box, click the radio box for Individually Linked Stories, then pick the 
CADIMAGE LEGENDS story and click OK.



Returning to the Choose Hotlink dialog, select the Cadimage Legends file, and click OK:

Next, in the Place Module dialog, click Place Module.

If the Paste Options… dialog appears, choose “Original Location” and “Zoom to Pasted 
Elements”, then click the Paste button:

Click outside the marquee to complete the placement of the Cadimage Legends Hotlinked 
Module. It should appear directly below the main Interactive Legends.



• CREATING VIEWS OF THE CADIMAGE LEGENDS

In the Navigator View Map, right-click on the LEGENDS | PLAN folder, and select Save Current 
View. In the Save View dialog:

1. Change the ID popup to None
2. Change the Name popup to Custom, then type in LEGEND 3D | CADIMAGE TOOLS
3. Make sure the “Ignore Zoom when opening this view” checkbox is NOT checked
4. Click the Create button

The new View will appear as the first item in the list for the LEGENDS | PLAN folder, and you 
may leave it there or reposition it below LEGEND 3D | ALL.

Click the minus sign to collapse up the LEGENDS | PLAN folder list, then click the plus sign for 
the LEGENDS | WORKSHEET folder (right above it) to expand that folder list. Double-click the 
LEGEND 3D | ALL view to show the Interactive Legends from their special worksheet as a Virtual 
Trace reference. Zoom out a bit, and you’ll see the Cadimage Legends sitting right below the 
main Interactive Legends.

Use the Zoom In button and carefully zoom in closely around the Cadimage Tools Legends. Then 
right-click on the LEGENDS | WORKSHEET folder, and choose Save Current View. 

1. Name this view LEGEND CT | CADIMAGE ALL
2. Make sure the “Ignore Zoom when opening this view” checkbox is NOT checked
3. Click the Create button

The new View will show up at the top of the LEGENDS | WORKSHEET folder list; you may leave 
it there or reposition it wherever you wish in relation to the other LEGEND views in that folder.



• OPTIONAL:  ZOOMED VIEWS & SAVED ZOOMS FOR LEGEND GROUPS
You may create zoomed views for each group of the Cadimage Legends inside a subfolder. 

Right-click on the LEGENDS | WORKSHEET folder, and choose New Folder. Name it LEGEND 
CT | CADIMAGE VIEWS, and click Create. Carefully zoom in on each Legend group, then right-
click on the LEGEND CT | CADIMAGE VIEWS folder and select Save Current View. Name the 
view appropriately, then proceed to the next group. When you are done, reorganize the Views 
within that subfolder as desired. 

Here is what we have set up in the MasterTemplate file that integrates the Cadimage Legends:

If you wish, set up Saved Zooms in the lower left navigation area. After zooming into each View of 
a Legend grouping, press down on the popup triangle next to the Zoom percent in the bottom left 
of the Worksheet window, and select Save Current Zoom… 

TIP: If you name these with a consistent prefix (e.g. “LEGEND CT | ”) they will group 
together alphabetically.



• PLACING THE RAPID DETAILER LEGEND INTO A WORKSHEET

If you own Rapid Detailer, we suggest you place a hotlink for its Legend (which is supplied in the 
Cadimage Legends PLN) into a new worksheet for convenient access. (If you don’t own Rapid 
Detailer, you may skip to the end of this section where you will save your reworked 
MasterTemplate TPL.)

Switch to the Project Map, and right-click on the Worksheets folder and select New Independent 
Worksheet. Name it “CADIMAGE TOOLS | RAPID DETAILER”, and if you wish, give it a 
Reference ID such as LG-06.

Once the blank Worksheet appears, click the scale button in the lower left of the window to set 
the scale to 1” = 1’-0” (Imperial) or 1:10 (Metric). You may also use the Quick Options palette to 
set the scale.

Go to the File menu > External Content > Place Hotlinked Module… and repeat the process you 
used to select a new hotlink referencing the Cadimage Legends PLN file. However, in the Choose 
Story dialog, this time select the RAPID DETAILER story:

Returning to the Choose Hotlink dialog, highlight the RAPID DETAILER hotlink, and click OK. In 
the Place Module dialog, simply click Place Module. If the Paste Options… dialog appears, 
choose “Original Location” and “Zoom to Pasted Elements”, then click the Paste button.

Click outside the marquee to finish placing the Rapid Detailer Legend into the Worksheet.

The next step is to create Views for the Rapid Detailer Legend. In the View Map, expand the 
INTERACTIVE LEGENDS (FAVORITES) > 2D LEGENDS (DETAILING | SECTIONS | 
ELEVATIONS) subfolder. Zoom in tight to the Rapid Detailer Legend, if you haven’t already. 
Right-click the subfolder, and select Save Current View. 

Name the View CADIMAGE  TOOLS | RAPID DETAILER | ALL. Double-check to make sure that 
the Layer Combination is set to * INTERACTIVE LEGENDS and that the “Ignore zoom when 
opening this view” checkbox is NOT set, then click Create.

We suggest you create a second View that has the Ignore Zoom checkbox checked, so that when 
appropriate you can easily return to this worksheet in the same location you last viewed. Simply 
repeat the Save Current View process, naming the View CADIMAGE TOOLS | RAPID DETAILER 
| NO ZOOM, while checking the Ignore Zoom box.

Here is a screenshot of how we have set up these Views inside the 2D LEGENDS subfolder:



• SAVE YOUR MASTERTEMPLATE TPL FILE

Save the TPL file, since you’re done with the process of adding in the Cadimage Legends into 
your custom MasterTemplate.

TIP: The last state of the TPL file is remembered when you start a new project. To 
simplify the environment when you start a project, we suggest that before you Save the 
TPL, you close down most of the View Map folders except MODEL / DESIGN VIEWS 
and the primary FLOOR PLANS folder. Also, close all windows except the 
PRELIMINARY DESIGN floor plan View and the INTERACTIVE LEGEND 
WORKSHEET.

You may now close your MasterTemplate TPL file. 

• If you need to rework or tweak your template later, use ArchiCAD’s File menu > 
Open…>Open… command and switch the file-type popup to TPL, then select your template 
file. Make the desired changes, Save and close the TPL file. 

• To start a new project, use the File menu > New… command and select Use a Template. 
The popup menu for template files should still be set on your custom MasterTemplate TPL 
file.



USE OF THE CADIMAGE LEGENDS
While you are working on a project, you may use the eyedropper with the Cadimage Legends in 
the same way as the standard Interactive Legends. This document describes suggested ways for 
AMT users to interact with Cadimage Tools. For complete information on usage, please refer to 
the documentation supplied by Cadimage Tools with your purchase of their products.

As with AMT’s standard Legends, the ID of each element has been set up with a prefixed letter Z 
(e.g. doors have ID’s of ZD01, ZD02, etc.). This prevents them from being listed in the standard 
AMT schedules, since these schedules have a Criteria based in part on the ID. At any time after 
placing an element, remove the Z and change the ID to D01 or similar; this will allow these doors, 
windows and other objects to be included in AMT schedules.

Except for Rapid Detailer, the rest of the Cadimage Legends are accessed through the special 
Legends Worksheet activated from the PRELIMINARY DESIGN View in the MODEL / DESIGN 
VIEWS folder.

You may zoom in manually to any part of the Cadimage Legends in that worksheet. You may also 
use Saved Zooms (in the lower left navigation area) or zoomed Views in the View Map to quickly 
navigate to legend groupings. (Setup of these zooms was described in the OPTIONAL section 
above. If you didn’t create them during the initial setup, you may do so at a later date by 
reopening the TPL file, adding them, then resaving the TPL.)

• SHAPE PRESETS

Cadimage Tools has developed a technology within many of their products to enable Presets to 
be stored and retrieved. These are similar to ArchiCAD Favorites, except that they refer to 
specific parts of the object styling rather than the entire element’s settings. For example, there are 
separate presets for door panels and for door frames.

Many presets are supplied by Cadimage Tools and installed in the ArchiCAD 13 / Cadimage 
Tools Extras / Defaults folder. The Cadimage Legends provides extra presets specifically for AMT 
users as part of the downloaded Cadimage Legends zip archive. Early in these installation 
instructions, you placed this AMT folder alongside the other presets inside the Defaults folder.

When you pick up an overall configuration for a window by eye-dropping it in the Legends, you 
get the styling for the frame, casing and wall inset. As with the standard Legends, all of these 
windows are initially set for a single fixed unit.

However, unlike standard ArchiCAD Library windows, Window Builder is a single very 
configurable library part. (Door Builder is similar.) This means that in order to switch to an 
operable slider, casement, awning or combination assembly, you don’t switch to a different library 
part - you interact with Window Builder’s dialog box to add additional units and define their 
operation. You may use these standard Window Builder techniques, or take advantage of shape 
presets supplied in the ArchiCAD 13 / Cadimage Tools Extras / Defaults / AMT folder.

Click the Setout category in the Window Builder Settings, then the Glazing option. In the Custom 
Settings area use the Open button (the one with the folder falling open; the tooltip says “Browse 
to Select a Preset”):



Browse for a shape configuration inside the Defaults / AMT folder (in this case inside the Exterior 
Doors Windows / Window Shape subfolder):

This will result in the following shape for the window, as shown in the settings dialog preview:



Shape presets are available for both Windows and Doors, and other presets are supplied for 
certain hardware options. Previews of all the window and door shape presets along with their 
names are shown as part of each Legend group, along with a visual reminder of this technique 
and the location of the AMT preset folder:



• EXTERIOR AND INTERIOR DOORS

Doors may be created using either Window Builder or Door Builder. Cadimage Tools suggests 
creating exterior doors with Window Builder to more easily match the styling of the exterior 
windows. 

For this reason, the Cadimage Tools Door Legend is divided into two sections, one for exterior 
doors (created with Window Builder) and the other for interior doors (created with Door Builder).

• RAPID DETAILER

Rapid Detailer is Hotlinked into a separate Worksheet since the elements are designed to be 
used at larger scales. To access the Rapid Detailer Legend, use the View set up in the 2D 
LEGENDS folder.

The view defined with the “ALL” zoom is useful for quickly seeing the overview of all the Rapid 
Detailer elements. The item set with “NO ZOOM” allows you to jump back and forth between the 
Detailer Legend and your active Detail window, remembering your zoom position. To complement 
this option, you may find it useful to check the “Ignore Zoom” checkbox in the View Settings for 
your active Detail in the Detail Clone Folder.



AMT  /  CADIMAGE WORK ENVIRONMENT
MasterTemplate does not require any special configuration of your Work Environment, however 
we recommend certain settings for optimum usage. You may adjust the Work Environment (WE) 
manually at any time using the Options menu > Work Environment submenu. The 
MasterTemplate Manual along with Release Notes for each revision of AMT provide guidance on 
which settings you may find useful to change.

In AMT 13, in response to numerous requests, we supply an AMT Work Environment profile in 
the standard AMT 13 download. This sets up a few extra keyboard shortcuts, and tweaks some
other settings. 

In general, to import a WE, open the Options menu > WE dialog, and choose Work Environment 
Profiles (the top-most item). Click the Import… button and navigate and select the main AMT 
folder, and ArchiCAD will search and find the AMT Work Environment Profile.

TIP: The Import Scheme dialog will attempt to look in all subfolders within a particular 
location for eligible files. If when you open the dialog, the path is set to a folder that has a 
large number of subfolders and files (e.g. My Documents), it may take a while before it 
displays the results, and may be unresponsive when you click the Browse… button. You 
may interrupt it by hitting the Backspace or Delete key on your keyboard, allowing you to 
use the Browse button without waiting for it to finish its current search.

To supplement the standard AMT Work Environment Profile, with the Cadimage Legends we 
supply a special Tool Scheme for use with Cadimage Tools. In the Work Environment dialog box, 
select Tool Schemes, then use the Import… button and navigate to the AMT CADIMAGE Work 
Environment folder (supplied as part of the Cadimage Legends download). Select the AMT-
Cadimage Tools 13 scheme and click Import. For more info on suggested settings for the Tools, 
please read the Cadimage Tools PDF document supplied within that same folder, or any later 
version available through the Cadimage Tools website.

For more information on manipulating Work Environment Profiles and the various Schemes that 
are subcomponents, please consult the ArchiCAD 13 Reference Manual.

SUPPORT
Support for the Cadimage Legends is provided to AMT licensees by Bobrow Consulting Group. 
BCG will answer questions via email to template@bobrow.com or on the MasterTemplate 
Support Forum (http://www.archicadtemplate.com/?page_id=310) without charge.

BCG is also available on a consulting basis to answer questions by phone or Skype, using 
internet-based screen-sharing technology provided by GoToMeeting. BCG can provide training 
on any level of ArchiCAD usage, guidance on Best Practices, as well as resolution of project or 
office-specific challenges including custom GDL programming.

Cadimage Tools provides support for the Tools themselves through their website 
(http://cadimagetools.com/) and via email to support@cadimagetools.com. Please send any bug 
reports or feature requests to support@cadimagetools.com. They periodically revise the Tools; 
you may check for and download minor updates through their website portal. 


