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Welcome to the latest version of the ArchiCAD MasterTemplate. The new update provides full 
compatibility with ArchiCAD 13, and also contains new features and revisions based on feedback 
and suggestions from users as well as our own discoveries and innovations. 

This document explains the new features, and outlines strategies for users upgrading from earlier 
versions of MasterTemplate.

NEW or CHANGED:

1) INTERACTIVE LEGENDS

a. We converted the complete Legend kit of parts from the ArchiCAD 12 Library to 
the ArchiCAD 13 Library. While some elements automatically found their 
counterparts in the new library, many dozens had to be swapped manually using 
parameter transfer techniques. Over 400 labels were also updated to reflect the 
new object names.

b. Added new Fills:

• Graphisoft-standard fills: two Image Fills (Blue Carpet, Parquet Floor) 
plus two Symbol Fills for Insulation

• New DEMO fill - can be used to partially cover up elements, making 
them appear dashed

c. Created many new Composite Wall types with integrated soft insulation fills, and 
added them to the Interactive Legend in the Advanced Modeling group. 

• See Notes for Advanced Users (below) for a method to show the 
insulation in section but not on plan.

d. Transparent fills were used to create a more elegant, cleaner look for the drop-
shadows around the legend groupings. New fills were created to provide a 
smooth gradient from 10% to 90%.

e. Restroom ADA Compliance (U.S. version only)

• Commercial Restrooms in Quick Rooms section have been adjusted to 
comply with ADA requirements

• Informative notes were added to show ADA minimums and maximums.

• Please refer to applicable codes to confirm compliance. However, if 
you see any issues that would affect general usage, please let BCG 
know so that we may resolve them.

f. Added Bed with Nightstands and Wheelchair Man (two new, useful objects in the 
AC13 library) to the appropriate areas of the Legends 

g. Cleanup:

• Font references were double-checked - everything now uses Arial 
Western, which should work cleanly cross-platform

• Corner windows in the Default Settings group were actually normal 
windows; they were replaced with actual corner windows



h. Extended functionality and changed the name of Object Indicator AMT label

• Added option to copy name of linked object into parameters, allowing 
one to drag a copy of these labels without losing the text name in the 
new independent label. (Note: this still needs work since it acts a little 
strangely.)

• NOTE: We are not using the new Embedded Library feature in 
ArchiCAD 13, because there are complications when embedding 
libraries into Hotlinked Modules. We continue to supply and reference 
a separate folder for the AMT Library.

i. Descriptive labels for library parts in the Quick Rooms and Matrixes have been 
moved to the Y | SPECIAL | LAYOUT SHEET & EXPLANATORY NOTES.2D 
layer

• This makes it easier to turn these labels off before copying a Quick 
Room into a project. (Copies of Quick Rooms may be brought into the 
project model to speed up laying out a preliminary design. All parts of 
the room grouping may be moved around or adjusted to suit the needs 
of the project.)

• NOTE: these descriptive labels are actually exploded into text and 
lines so that they are independent of the associated library parts -
otherwise after eye-dropping one of the objects, a new linked label 
would be inserted automatically when placing a copy of the object (not 
generally a good idea).

2) Simplified Preliminary Design process (see explanatory section below)

a. New *PRELIMINARY DESIGN Layer Combination (LC) shows all modeling and 
basic annotation elements

b. New View PRELIMINARY DESIGN using this LC

c. New View for INTERACTIVE LEGEND WORKSHEET without Zoom (placed in 
the MODEL PLAN VIEWS (FOR DESIGN) section of the View Map) with the 
same LC - this simplifies toggling back and forth between the kit of parts and the 
developing model

d. This LC also was applied to all the Interactive Legend Worksheet zoomed Views
for the same reason

3) More attractive opening screen

• Less clutter and more explanatory notes

4) Cleaned up several Layer Combinations and Layer settings

a. Demo layers (A | DEMOLITION | 3D.DEMO and A | DEMOLITION  UPPER | 
3D.DEMO) are now turned off for most Layer Combinations except Demo Plans;  
they are turned on for Model Views to enable easy manipulation of layers during 
design - they can be turned off by the user for any Layer Combination if preferred

b. CONDOC DEMOLITION - Layer Combination has been revised to show more 
appropriate layers

c. U | DRAWING | DEMOLITION - layer name had a typo that has been corrected



d. Non-Plot Layer

• A | NON-PLOT (HOT SPOTS & TEMP ITEMS) is now turned off for all 
CONDOC Layer Combinations, and on for Model Views

• Hotspots in the template (used to set initial extent boundaries of Views) 
have been moved to the ArchiCAD Layer

• The Hotspot tool is now set to use the ArchiCAD Layer by default

5) NEW: Work Environment Profile - this can be imported in whole or in part to set
keyboard shortcuts and other preferences based on our recommendations

a. New keyboard shortcuts (Shortcut Schemes)

• Last 3D Document - Shift+3
• Last Detail Drawing - Shift+2
• Last Elevation - F8
• Last Interior Elevation - Shift+I
• Last Worksheet - Shift+W
• Tool Settings - “.” (period) in addition to standard Ctrl+T / Command+T

b. Info Box (Tool Schemes) - moved ID and Label Elements to beginning (left side)
for Windows, Doors and Objects

c. Dialog Boxes and Palettes (User Preference Schemes) - checked box for “Hide 
Locked Layers in Pop-Up Palettes”

d. Palette Schemes - Quick Options palette is set up to show under Navigator

6) Layout Book and Publisher

a. Small Project Set - removed “A” prefix from Subset name

b. Added new Publisher Set for Small Project Set



Initial Download and Setup
The AMT 13 U.S. version was posted for download on October 11, 2009. The International 
version is expected to be released later in October.

The zip file will expand into (U.S. names shown, the International version will have INT in place of 
USA):

• MasterTemplate 13 USA TEMPLATE.tpl
• MasterTemplate 13 USA LEGENDS.pln
• MasterTemplate 13 USA LIBRARY
• MasterTemplate 13 Release Notes.pdf
• AMT Office Favorites.mod
• AMT Project Favorites.mod
• AMT Work Environment [folder]
• MasterTemplate NEW PROJECT FOLDER

To install AMT 13, download the zip file to your workstation, then unzip it to a convenient location 
into new folder. We recommend placing this into your ArchiCAD Office Standards folder; a good 
place for this is in the Jobs folder on your hard drive or on the office server.

AMT 13 file uses three Hotlinked Modules (HLM): one refers to the MasterTemplate 13 USA 
LEGENDS.pln (kit of parts), a second to the AMT Office Favorites.mod, and a third to the 
Project Favorites.mod. 

When you open up the TEMPLATE you'll get a message saying that these three Hotlinks are 
missing, since everything is now on a new workstation. Go to the Hotlink Manager (either directly 
from that message, or from the File menu > External Content > Hotlink Manager) and relink these 
references to the file locations on your hard drive or network.

When you open the TEMPLATE file, you will also get a warning about missing PDFs - these are 
referenced in the Layout Book and used for the specifications and general notes pages. As with 
all previous versions of AMT, you can resolve this warning message once and for all by using the 
Read From… button and choosing the MasterTemplate 13 USA Library. ArchiCAD will search 
within the library folder and subfolders, and find the PDF files and relink them. Later, when you 
save the TEMPLATE, all of this will be remembered, so you won't have to deal with them again 
(unless you move the files or decide to change the references).

The Library Manager should be able to find what it needs: the ArchiCAD 13 Library as well as the 
MasterTemplate 13 USA (or INT) Library. If you place the template file into a different folder than 
where you store the MasterTemplate Library, you will need to tell the Library Manager to load that 
folder as a Linked Library. 

You now have a new version of AMT to explore! We suggest you read through these Release 
Notes to see what's new, and then decide how you want to transition your own version of AMT. At 
the end of this document, various approaches will be discussed for how to integrate the new 
version of AMT with your previously customized template.

Please report anything requiring cleanup in an email to template@bobrow.com. We hope you 
enjoy the new features of AMT 13. Thanks again for the opportunity to work with you!

Eric Bobrow
Bobrow Consulting Group
October 11, 2009



Simplified Preliminary Design

One of the biggest changes in MasterTemplate 13 involves subtle adjustments in Layer 
Combinations and Views. We continued to develop the ideas implemented in AMT 12.1 to make 
the first stages of design even simpler. Changes to the Views and Layer Combinations allow 
quick access to the Interactive Legends without interrupting the workflow.

One can now toggle back and forth between the floor plan and the kit of parts using the two views 
PRELIMINARY DESIGN and INTERACTIVE LEGEND WORKSHEET in the top area of the View 
Map:

A new Layer Combination called *PRELIMINARY DESIGN is used for both of these views, so 
there is no change in layer visibility whether one double-clicks on the Views or uses keyboard 
shortcuts (F2 for the floor plan, and Last Worksheet / SHIFT+W to go to the Legend Worksheet). 
Both of these Views are set to ignore the zoom, so you’ll always return to the location and zoom 
where you were looking or working.

This Layer Combination is set to show all 3D elements and most 2D annotations (other than 
marker callouts) so you can draw almost anything and not worry about changing the layer 
combination. The Structural Grid layer (S | GRID.3D) is turned off so that the placeholder grid 
elements are not in the way when one starts, but can be turned on for this layer combination if 
and when preferred.

The net effect of these changes is that you can draw and model freely and go back and forth to 
the kit of parts very quickly as needed. It should also be much easier for new users to understand 
and start using the template legends without any complications regarding layer management.

As in AMT 12.1, the Legend Worksheet has a popup for saved zooms that facilitates jumping to 
various sections:



Alternatively, one can open up the INTERACTIVE LEGENDS (FAVORITES) section of the View
Map to get access to these saved zooms with a double-click on any of the Views inside the 

LEGENDS | WORKSHEET folder.

As in AMT 12.1, the preferred method of 
access to the Legends is through this
Worksheet, which uses Virtual Trace to show 
the Legends from the Plan View. Each saved 
View in the LEGENDS | WORKSHEET jumps 
to a specific location or group of parts or Quick 
Room. This is exactly the same as using the 
INTERACTIVE LEGEND WORKSHEET View 
(in the MODEL PLAN VIEWS above) then 
using the popup menu to zoom to that area of 
the worksheet. 

The LEGENDS | PLAN folder of Views is 
retained for two special purposes, but is no 
longer recommended for quick access for eye-
dropping the kit of parts. 

Each of these Views jumps to a different part 
of the floor plan where the Legends are placed 
as a Hotlinked Module (HLM). By necessity the 
View changes the Layer Combination to show 
the Master Layer of the HLM for the Legends. 
To return to the working model, one then has 
to reactivate the previous Layer Combination 



and navigate back to place the new element. This method, dating back to the original 
MasterTemplate, requires many more clicks, and is much more confusing than our current 
methodology.

Beyond historical reasons, the LEGENDS | PLAN folder is needed for the following:

• The first View (LEGEND 3D | ALL) in that folder is used as the Trace Reference for the 
Legend Worksheet. This View should not be deleted; otherwise the Trace Reference for the 
Legend may not function properly in the Worksheet views.

• To copy a Quick Room, use the corresponding View in the LEGENDS | PLAN folder; outline 
the room assembly with the marquee tool or use the arrow tool to select the elements, then 
copy; return to the desired area of your model (using the appropriate View or manually 
resetting the Layer Combination, and navigating to the correct story and zoom location) and 
paste.

Quick Rooms were introduced into the Interactive Legend in AMT 12.1 as a tool for speeding up 
preliminary design conceptualization and program planning. Entire room layouts can be copied 
from the Legend into your project, and used as is, or modified as needed. All parts (objects as 
well as the containing walls) can be moved around, changed or deleted to suit your design.

Note that the descriptive labels that indicate library part names are on the Y | SPECIAL | 
LAYOUT SHEET & EXPLANATORY NOTES.2D layer, and will be copied along with the room 
assembly. To avoid bringing them along, we suggest you turn off that layer before copying the 
Quick Room. You may turn this layer off manually in the Layer Settings dialog, or (with groups 
suspended) right-click on any text description and choose from the context menu Layers > Hide 
Layer.



Work Environment Profile

After numerous requests from AMT users, we created a Work Environment Profile with 
recommended Keyboard Shortcuts and other preferences set up for AMT. This is supplied as a 
folder exported from the Options menu > Work Environment > Work Environment Profiles.

To use the supplied Work Environment Profile, choose the Options menu > Work Environment > 
Work Environment… command. Click the Import… button from the Work Environment Profiles 
section.

In this Import Profile dialog box, press the Backspace or Delete key to stop ArchiCAD from 
searching in its default location for Work Environment (WE) Profiles. Then click the Browse… 



button and locate and select the AMT folder. ArchiCAD will then find the available WE Profiles in 
that folder. Select the AMT Work Environment Profile from the list, and click Import. Next, 
highlight the imported profile and click Apply Schemes of Profile, then OK.

Note that this Work Environment Profile will overwrite all previous customization of your Work 
Environment. If you prefer, you may selectively import only some of the settings, by going to any 
particular scheme - for example, Shortcut Schemes - and clicking the Import… button. This will 
only search for and bring in the AMT keyboard shortcuts.

For more information on management of the ArchiCAD Work Environment, please refer to the 
ArchiCAD Help or the ArchiCAD Reference Guide.

NOTE: The Work Environment Profile feature of ArchiCAD MasterTemplate 13 is brand new and 
we would appreciate your feedback if you notice any issues or would like to offer suggestions. 



NOTES FOR ADVANCED USERS

EMBEDDED LIBRARIES

The AMT library has been partially updated, and is supplied as a separate folder within the 
download files.

We are not using the Embedded Library feature in ArchiCAD 13, because of complications 
caused by embedding libraries into Hotlinked Modules (HLM). If you embed library parts into a 
HLM, then the project file referencing the HLM will see those parts. That is good, but there can be 
some issues. 

If you embed these parts directly into the project file (as well as into the HLM), you will get 
duplicate parts warnings. If you do not embed them again, and later delete the HLM from your 
project file, you will have missing parts, and possibly even missing data. 

If you embed the same parts into multiple HLM’s (for example, the Office Favorites as well as the 
main Legend file), you will also get warnings of duplicates. 

For these reasons, we have opted to use the traditional method of referencing a library folder 
(now called Linked Libraries) rather than embedding these parts.

SOFT INSULATION

Some users have asked for a way to show the insulation fill in sections and 3D Documents, but 
hide it on the floor plan. A special new penset has been created for this purpose.

The soft insulation commonly will be drawn with the same pen as other wall cut fills. However, 
this skin is defined in the composite to use a special pen.

When Apply Structure’s Settings is checked in the Wall Settings for the Cut Fill Pen in Floor Plan 
and Section… > Cut Surfaces, this pen will draw as a thin grey in standard pensets, but will be 
white (hidden) in the special penset.

The special penset is named US AC-10 Default | PENS 1-20 ALL* BLACK | PLOTTING (*INSUL 
WHITE). In the international version of AMT, it has a similar name with (*INSUL WHITE) 
indicated.

This new penset is not used by default, but may be chosen for floor plan drawings in the Drawing 
Settings if one wants to hide the insulation fill on plan. 

In order to achieve this effect, one also has to click the checkbox (Apply Structure’s Settings for 
the Cut Fill Pen) for the actual walls placed on plan.

TRANSPARENT FILLS and the INTERACTIVE LEGEND GROUPINGS

The borders of the Interactive Legend sections have a soft drop-shadow created by groups of 
fills. In previous versions of AMT, this visual effect was prepared using fills with different pens and 
percentage densities, to simulate different shades of grey. Because they used an opaque white 
background pen, the drop shadows were somewhat crude looking when viewed against a colored 
background fill.

In AMT 13, two different methods were implemented to create a cleaner, softer effect.

In one, the fills are all done with the same dark pen, but with different percentages of opacity 
ranging from 100% down to 10% in increments of 10%. This required creating a number of new 



Fill types with different percentages. These newly created Fills are available for other purposes, 
since they show up in the standard options for the Fill tool.

Another approach used the new ArchiCAD 13 feature of gradient fills with transparent 
backgrounds. In this case, a single fill on each side with a linear gradient, and one for each corner 
with a radial gradient, are able to accomplish a similar effect.

Most of the drop shadows in the Legend are done using the first approach, with a couple of them 
experimenting with the second method. The reason why we did not switch all of them to the 
second technique is that there appeared to be a bit of a slowdown in redraw times, and there was 
some concern that substituting this for all of the Legend groups might cause issues for some 
users depending on the speed of their display card.



UPGRADE GUIDE: 
Integrating MasterTemplate 13 with Your Existing Template

There are two basic approaches for integrating the new version of the ArchiCAD MasterTemplate 
with customized templates created on earlier versions.

1) Start over with the new ArchiCAD MasterTemplate 13, and customize it again. This 
approach is ideal for users who have not done much customization to MasterTemplate.

2) Add the new components of AMT 13 to your existing template. This is best for 
experienced users who have done a lot of customization that they don't want to repeat.

3) If you are upgrading from a version earlier than AMT 12.1 (e.g. AMT 12, 1.1 or 1.0), the 
choices are similar, however option 2 becomes more complex because many features 
were added to the file structure in AMT 12.1.

General Guidelines

Always save a copy of your existing (older) template before creating your new version. That way, 
you’ll have it available if for any reason you need to refer to it, or need to work in an earlier 
version of ArchiCAD.

AMT Library

The AMT library has been partially updated. Load the new AMT library folder as a Linked Library, 
instead of referencing your previous version. See the Notes for Advanced Users section of this 
document for an explanation of why we use Linked Libraries rather then embedding these parts.



1) UPGRADE GUIDE: 
How to Integrate Previous Customization into MasterTemplate 13

If you only modified the standard MasterTemplate a small amount, then it may be best to start 
over with the new AMT 13 and rework it again to suit your needs. The simplest way to copy and 
reuse what you changed in AMT is to open up two sessions of ArchiCAD 13. 

In one session, open the standard MasterTemplate 13 TEMPLATE.tpl file. We suggest you 
immediately save this under a new name specific to your office, so that you don't overwrite the 
standard base version of the template in case you need to access it again. Choose the option to 
Save As an ArchiCAD Template (TPL format) so that the file will be usable as a Template file 
rather than as a PLN project file. We’ll call this your New MasterTemplate.

In the other session of ArchiCAD 13, open your own custom template, the reworked version of an 
earlier MasterTemplate TEMPLATE.tpl file. We suggest you do a Save As for this template
(which you have just opened up in ArchiCAD 13, perhaps for the first time). Use a new name so 
you won’t risk overwriting what you were using for a previous version of ArchiCAD. We’ll call this 
your Custom MasterTemplate. You can save this as either a TPL or PLN file, since we’ll only be 
using this as a source reference for copying information, then discarding it.

Layout Masters

You most likely have adjusted some or all of the Layout Masters. In your Custom 
MasterTemplate, go to the Layout Book and open up the Masters folder, then double-click on the 
first Master that you have customized to open it up. Activate the Arrow tool (if it's not already) and 
Select All (CTRL-A or CMD-A), then Copy to the Clipboard. Switch to your New MasterTemplate
(the other session of ArchiCAD) and find the same Layout Master; Select All and Delete the 
contents; then Paste in the contents that you Copied from the Custom MasterTemplate file.

Repeat this for each Layout Master that has been customized. If you deleted any Layout Masters 
in your Custom MasterTemplate in order to shorten your Master list, you may want to delete the 
corresponding ones in your New MasterTemplate.

Schedules

If you have added or customized Schedules in your Custom MasterTemplate, you can save these 
as XML files that can be imported into your New MasterTemplate. Double-click one of the entries 
in the Project Map > Schedules > Element list. Click the Scheme Settings… button and review 
the Schemes listed, and highlight one that is new or revised. Click the Export… button to save as 
an XML file; choose a folder to store it that you'll be able to locate easily, and give it an 
appropriate name. Repeat the Export action for each schedule in the list you want to transfer.

Switch to your New MasterTemplate file, and open up one of the Schedules, then click the 
Scheme Settings… button. Click the Import… button and locate the folder in which you saved the 
XML files. Choose the first one and Import it. Repeat for each one in the folder. 

You may find you have redundant schedules: ones from AMT 13 with the same names as those 
you imported from your Custom MasterTemplate file. Review each pair of schedules that has 
duplicate names and figure out which one is "yours", and then use the Delete button to get rid of 
the other.

On each Layout with a Schedule that refers to one that you have deleted and replaced, select the 
Schedule and right-click, then choose Link Drawing To. Choose the option at the top for "an 
internal View" then select the appropriate Schedule from the SCHEDULES (CLONE) folder.



Element Attributes (Materials, Fills, Composites / Wall Types, etc.)

If there are any Attributes you have added, such as Materials, Fills, Composites / Wall Types, 
etc., you can use Attribute Manager to transfer them. 

In your New MasterTemplate, open the Options menu > Element Attributes > Attribute Manager. 
Then on the right side of the Attribute Manager dialog box, click the Open… button and browse 
for your Custom MasterTemplate. 

You will be able to select Materials, Fills, Wall Types, etc. from the right side file (your previous 
template), and Append them to the left side (the New MasterTemplate file you are customizing). 
Do not use the Overwrite button unless you know exactly what this means and feel that it is 
appropriate.

Other Customization

There are many ways to customize MasterTemplate. If you choose to follow this method 
(transferring your custom elements manually from your old Custom MasterTemplate to the New 
MasterTemplate file), you will have to go through your Custom MasterTemplate manually and 
copy each element or area that you've modified, then go back to the New MasterTemplate file 
and paste them in.

Remember that you do not have to get this "perfect" in one session. You should retain the old 
Template file in case you need to access it later. You can always go back and get something you 
missed.

When you are done (for now), be sure to save your file as a TPL (if you haven’t already). Then to 
test it, choose File menu > New and select Use a Template, then Browse… for New 
MasterTemplate TPL file. You should then get an untitled copy of the new template, and see all of 
your modifications in this untitled PLN file. The next time you create a new project file, this 
template TPL file will be the default in the popup, so you won’t have to browse to select it.



2) UPGRADE GUIDE: 
Integrating the New MasterTemplate 13 Features into Your Highly 
Customized MasterTemplate 12.1 File

If you are an experienced user and have done a lot of customization to MasterTemplate, you may 
prefer to add to your existing template some or all of the new features of AMT 13. That way you 
can choose exactly what you wish to add or change.

We suggest you review the new features outlined in these Release Notes carefully to understand 
what has been added or modified in AMT 13. Open up the standard AMT 13 Template and study 
it, and see how all the new things work. Then choose what you want to add to your own template, 
and use methods similar to the previous section to transfer what you wish.

As with any project file, to move your Custom MasterTemplate forward, you may simply open it in 
ArchiCAD 13 and save it. This will now be an ArchiCAD 13 file. We suggest you save it with a 
new name or in a new folder, to avoid overwriting the earlier template file in case you need to do 
any work in your earlier version of ArchiCAD.

Initially, this New MasterTemplate will reference the ArchiCAD 12 Library. You will need to use 
Library Manager to switch it to use the ArchiCAD 13 Library, plus (at least temporarily) the 
ArchiCAD 12 (and/or 11) Migration Library. To get a “clean” template, you’ll need to switch out all 
parts in your template or Legend that refer to legacy libraries. In MasterTemplate, the references 
to library parts are primarily found in the Interactive Legends.

Interactive Legends

The Interactive Legends from earlier versions of AMT used the ArchiCAD Libraries current at the 
time. It is not generally a good idea to migrate templates forward with references to these legacy 
library parts, since it requires loading both the ArchiCAD 13 Library and Migration Libraries for 
every project. It’s better to update the Legend to use only the 13 Library plus specific custom 
parts you wish to use (which includes AMT-supplied parts as well as any of your own).

To resolve this issue in your Custom MasterTemplate, you may:

• Switch the Interactive Legends to use the new AMT 13 Interactive Legends based on the 
ArchiCAD 13 Library, or 

• Selectively bring in whatever parts of the new Legends you find useful.

If you haven’t customized the Legends, simply relink the Hotlinked Module for the Legends in 
your template to use the AMT 13 version. Open the File menu > External Content > Hotlink 
Manager, then select MasterTemplate Legend.pln from the list, click Relink, and browse for the 
new version of the file. You may need to switch the popup menu for file type to PLN file in order to 
see and select the MasterTemplate Legend.pln file.

If you have customized the Legends, then you’ll need to copy and paste between your Custom 
Legend and the New Legend. Open up the AMT 13 LEGEND file and copy whichever parts you 
wish to use. Paste them into your own version of the Legends, and rearrange the Legend group 
positions as desired. 

For every part in your custom Legend file that is based on a legacy library, you should switch it to 
use the new library. Select it and in the Object (or Window or Door) Settings dialog, navigate to 
the corresponding part in the AC 13 Library, and click to switch to that part. Adjust the parameter 
values to get it the way you prefer.



If you wish, you may use parameter transfer:  hold down Option-Command or ALT-Control to get 
the syringe, and then click with the syringe to switch to the new part while transferring the values 
of all corresponding parameters. Verify that your part looks correct in both the 2D and 3D 
previews, and then click OK. Repeat for every part referencing a legacy library.

Once you have cleaned up all references to legacy libraries, return to Library Manager and 
remove the Migration Library. If the Library Loading report shows missing library parts and you 
see the special dots indicating missing parts on your floor plan, make a note of what you need to 
fix then reload the Migration Library and swap these legacy parts for current ones. Check it again, 
and repeat until you have a clean Legend that uses only the AC13 Library and has no missing 
library parts. 

If you have an Office Favorites HLM module separate from the main Legend PLN file (as
introduced in AMT 12.1), you will need to open that up and update it to use the ArchiCAD 13 
Library instead of an earlier ArchiCAD Library. To open the Office Favorites file, you may select it 
in the File menu > External Content > Hotlink Manager, then click Open in Separate ArchiCAD. 
Follow the same process as above.

If you have a Project Favorites HLM module, be sure to check it for legacy parts, then save a 
version in ArchiCAD 13 format.

For simplicity, put all your Hotlink Modules (the LEGEND as well as Office Favorites and Project 
Favorites) into the same folder as your Custom MasterTemplate for ArchiCAD 13.



3) UPGRADE GUIDE: 
Migrating from MasterTemplate 12 or earlier

The Interactive Legend was substantially expanded in MasterTemplate 12.1. If you are upgrading 
from a version of MasterTemplate prior to AMT 12.1 (AMT 12, 1.1 or 1.0), it is simplest to use 
AMT 13 and repeat your customization (see section 1 above). 

However, if you did a lot of customization, you may choose to add selective parts of the new 
Legend system. Follow the general guidelines in section 2 above. However, since many 
enhancements were made to the file structure and the Legend layout in AMT 12.1, there are 
additional steps if you wish to take full advantage of all the innovations in the current 
MasterTemplate.

The following notes are adapted from the AMT 12.1 Release Notes, and explain how to add in the 
new features introduced in AMT 12.1 to your version of the Legends and the template itself.

Interactive Legend Expansion and Reconfiguration

The Legend file itself was substantially expanded in AMT 12.1 with the addition of Quick Rooms 
(room arrangements that may either be studied or copied into your project to speed up 
preliminary design layouts) and Matrixes (groups of related objects). In AMT 12.1 and later, these 
new sections of the Legend are also referenced in saved 3D Views and 3D Documents.

You may replace your own Interactive Legend file with the new one in AMT 13 (see notes in step 
1 above). Alternatively, you may copy and paste parts of the current Legend into your own 
version, or the reverse (adding in your components into the AMT 13 Legend). Be sure to rework 
your Legend to use the current Library (see step 2 above) as part of the update process.

Legend Placement on Ground Floor

If you want to use the concept of 3D Views and 3D Documents with your custom Legend, we 
suggest you move the Legend from the -1 Story to the Ground Floor. This will reduce the story 
offset issue when using the eye-dropper on Legend elements in 3D (see the explanation in the 
section on 3D Views and 3D Documents in the AMT 12.1 Release Notes). You may either Cut the 
Legends from the -1 Story and then Paste them onto the Ground Floor, or delete them from the 
lower story and place them fresh on the Ground Floor.

If you move the Legends from one story to another, you will need to recreate the Views of the 
Legend in the View Map that refer to the different sections of the Legend. This is because each 
View, once created, is linked to a specific source location (in this case, the floor plan story) which 
cannot be changed. Zoom in on each area of the Legend in its new location (story), and select 
the Save Current View option from the bottom of the View Map, then name the View 
appropriately.

Legend Worksheet

To use the new Worksheet access for the Legend, simply create a new Independent Worksheet. 
You don't have to draw anything in it. Open this worksheet, and then right-click on the View that 
refers to the Interactive Legend from the Plan, and choose Show as Trace Reference. Then in the 
Trace and Reference palette, choose the option to show the Reference in Original Color.

In this worksheet, to quickly jump to specific areas of the referenced Legend, go to each area of 
the Legend then use the Zoom popup in the bottom left area of the worksheet window (the small
triangle next to the percentage zoom value), then choose Save Current Zoom… and name it 



based on the Legend section name. Repeat for each zoom you wish to record - perhaps one 
overall zoom and as many as 20 individual ones to point to each Legend area.

Create at least one View in the View Map to reference the Worksheet with the *PRELIMINARY 
DESIGN layer combination, and click the checkbox to Ignore Zoom when opening the view. This 
will bring up the Legend Worksheet to the last zoomed position.

You may create multiple zoomed Views in the View Map for the Worksheet itself, as we did in 
AMT 12.1 and 13, but this is not actually necessary. You may simply open the Worksheet from 
the View created in the previous paragraph, and use the Zoom popup to gain quick access when 
a different part of the Legend is needed.

You may also open the Worksheet from the Project Map, or using Go To Last Worksheet from the 
context menu, Toolbar popup, or keyboard shortcut. This will bring up the Legend without altering 
the active Layer Combination (as would happen when you double-click a View). 

Legend Views - 3D

To create the saved 3D Views of the Legend, activate one of the original (or recreated) Views that 
goes to the Legend on the Plan (not the worksheet version). Then draw a marquee around a 
section of the Legend, and choose Show Selection/Marquee in 3D. That should give you a 3D 
view of the Legend grouping you chose. Orbit around until you get an angle you like. Save as a 
new View in the View Map, and repeat for each Legend area that you wish to access. Make sure 
you use an appropriate Layer Combination when creating the 3D Views.

You can create your own 3D Documents for these 3D Views of the Legend groupings as well. 
Once you have a 3D View that you wish to use, simply right-click in empty space and choose the 
Capture Window for 3D Document… command. Give it an appropriate name, and it will show up 
in the Project Map as a new 3D Document. You'll need to do one additional step: save the view of 
the 3D Document in the View Map (as usual, clicking the Save Current View button from the 
bottom of the View Map).

Office Favorites and Project Favorites

In the Template itself (as opposed to the Legend file), you may choose to add the Office Favorites 
and Project Favorites modules to the Legend area. These concepts were introduced in AMT 12.1, 
and may simplify your future customization of AMT by focusing it on files that are separate from 
the main Legend file.

In AMT 12.1 and later, blank areas are included in the main Legend file, and these are used for 
placement of the Office Favorites and Project Favorites. All three are placed into the Template file 
itself. The idea is that:

• The main Legend PLN is updated rarely (perhaps only when we release a new version of 
MasterTemplate).

• The Office Favorites MOD may be periodically updated or expanded, and always show the 
latest version for all projects.

• The Project Favorites MOD file (if used) is copied and separately maintained for each actual 
project file.

Element Attributes



When you paste in the new Legend either as a whole, or just the Quick Rooms and Parts 
Matrixes, the new Composite Wall Types, Materials, Fills and Layers are brought into the file 
automatically. You won't need to use Attribute Manager to import them.

These should also become available in your Template file when the Legend HLM is updated in 
the Hotlink Manager.

The Layer Combinations for *PRELIMINARY DESIGN as well as the plan for SMALL SCALE
drawings will not come in during this process. To add or rework layer combinations, you will need 
to create or adjust them manually. Also, please review the layer combinations in AMT 13 for 
updates related to DEMO layers and DEMO layer combinations, and rework your template if you 
wish. Other minor adjustments may be needed to reconcile the handful of new layers we added.

As noted in the previous section, this process of integration does not need to be done all in one 
session. You may bring in some of the new features of AMT 12.1 and 13 into your existing 
template, then return later to pick up others that you missed or have decided to include.


